4K Ultra HD Dilemma

Last week I bought the Star Wars: The Skywalker Saga box set from Best Buy. Today, for May The 4th, I popped in the 4K Blu-Ray of Episode IV: A New Hope to watch. The movie played perfectly for the first forty-five minutes, but at around the Jabba The Hutt scene, the disc started to glitch. Parts of the screen started to suddenly pixelate, and the picture started to lag so it didn’t synchronize with the audio. I took the disc out and tried to rub off any fingerprints/slight scratches/dust and put it back in. For a minute, it started to work fine again, but then at the “Alderaan’s Fate” scene, the same thing happened again. I took the 4K disc out, put the regular Blu-Ray in, and started from that scene. The movie played perfectly from there on out.

I haven’t tried watching any of the other discs in the box set, but I’m kinda worried. Since I already opened the box set, I can’t return it to Best Buy. I guess I can’t judge too quick, since I’ve only tried out two of the 27 discs included with the set. But this issue has been bugging me all day. Has anyone else had this issue with a 4K Blu-Ray (Star Wars or otherwise)? And if so, is there a way to fix it?

P. S. I was playing this off of an Xbox One that has successfully played 4Ks in the past.

Update: I put in the Empire Strikes Back 4K today, and it was the same scene all over again: just shy of an hour in, the disc glitched like ANH’s did, so I had to switch it out for the Blu-Ray, which worked perfectly fine.

1 Like

From a quick bit of research, it’s possible that disabling HDR could help. That’s a real shame if so, but would at least mean you can watch them in some form for now.

2 Likes

Thanks for the advice. Would you mind giving me some basic instructions, as I’m not very well-versed in Xbox One hardware?