Corrupted Save Files On Nintendo Switch

So last fall I got Lego DC Supervillains for the Nintendo Switch, and I finally beat it 100% in April. No problems with the game whatsoever. However, this week I decided to do another playthrough of it and encountered an issue. After I finished the first level, the game froze. I went back to the Home screen and disabled the game. When I restarted it, the second save file (the one I’d just started) was labeled as “corrupted.” So…I did the “New Game” feature and overwrote the corrupted save data. Over the course of a couple days, I played through the main story campaign, up until the “Darkseid Of The Moon” level. Then I decided to take a break from Lego DC Super Villains to play another game, so I exited out the game again.

Well, tonight I fired up Lego DC Super Villains again, and it’s the exact same “corrupted file” nonsense again. I know for a fact that my game was saved, but now it’s supposedly corrupted. I tried uninstalling and reinstalling the game software, but that didn’t work. I even did a software scan on the Switch’s “settings” tab, but it said nothing was corrupted. And now I don’t know what to do.

Anyone have any ideas?

1 Like

I have the same issue. I fuess it doesn’t like to have two files.

Yours is the digital one not the cartridge right? Because it might be because of the digital version.

1 Like

No, it’s the cartridge. I actually asked my brother if I could try downloading the software from his cartridge (which hasn’t presented this kind of problem, and he says he’s done multiple playthroughs). But he said “I only use them for my own.”

Hm ok. Really weird…

1 Like

Yeah, I have no idea what to do.

1 Like

I’ve never heard of something like this before. I’m curious, have you tried to touch your original save file again? Might be an issue with the cartridge as a whole. Regardless, You’ll probably need to skim across the wider internet to figure this out.

1 Like

No, I haven’t tried to touch the original save file. I actually tried to do a new game on Slot 3. I did the first 2 levels and then quit the game. Back on the Home screen, the Slot 3 was now “corrupted,” too.

That’s exactly what I did before making this topic. I tried every hint I found, but to no avail. And apparently, the Nintendo Switch isn’t the only platform that has presented this problem with Lego DC Super Villains.

https://gamefaqs.gamespot.com/boards/240046-lego-dc-super-villains/77352934

Actually, what I might try next is deleting all of the game’s save data from my Nintendo account. If I understand correctly, the games I’ve saved so far are in my account, not on the console itself. So maybe if I find a way to wipe every one of my save slots, then that might do the trick.

1 Like

Ohhh, okay. That’s tough luck, always sucks to find a glitch like that in a game you like.

Yeah, that sounds like your best bet. Just a shame that you’ll have to delete the 100% file.

2 Likes