I'm having trouble editing my posts...

The title is self-explanatory. For the last few days, I’ve been largely unable to edit posts of mine. Sometimes it works just fine, but on most occasions I’ve only been able to edit the first sentence. This is a bit bothersome because I need to update some posts of mine many times as part of an RPG I’m running right now, but it’s been hard for me to do that.

Is anyone else experiencing this? Is there a limit to how many times you can edit, and am I just reaching that?

1 Like

A long time ago, I was having the same problems, but worse. I wasn’t able to edit my posts at all. As far as I know, it is just some sort of temporal bug.

I’m dealing with it as well, I find that if I double click my post’s content and reload the page that it should go back to normal and allow me to edit. Tho it can take a couple reloads.


I too have been experiencing this, even on mobile.

I managed to fix it somehow, but only for the one post I did it on. Like @Jcton said, double-clicking to highlight all the text can sometimes work, but I couldn’t tell you how I fixed it.

@Mod_Squad any news on this? Site bug?

1 Like

How many edits are each of you making per day, as the maximum per day is 30, If you’re not reaching the maximum, then we’ll look into it

Also, side note, please don’t @ the mod squad tag as none of us will get notifications for it. Please at any of us directly instead

1 Like

While I make a few per day, I don’t believe I reach 30 very often. This has lasted for a few days, and has prevented me from doing a lot of editing in that time, so I certainly haven’t been reaching the limit recently.

@Jcton’s trick has worked for me a few times, though, so I thank him for sharing it with me.

I barely make more than 5 edits a day. The most I’ve done is the edits for a story page or that project I’m working in that one suspect place.

Like everyone else, barely any a day. Both times I experienced this bug it was directly after posting.

1 Like