The Stud.io Pack Formerly Known as The Biopack

Good pack awesome parts

Hey, great stuff! I’m looking for 57526 and 57541, Toa Mahri Nuparu’s shoulder and thigh armor pieces. Any chance you have plans to model these and add them to this pack? never mind, they’re already there, thanks!

I believe those pieces are already included in the pack

(Welcome to the boards by the way!)

1 Like

Ah, yes, I didn’t see them in the preview image above so I assumed they weren’t there, but now that I’ve installed the pack I see them.

Thanks for the welcome!

2 Likes

You sure the google drive link doesn’t have any viruses, right?

Are there any plans to add more from 2009/2010? I understand that this was to be the final set of additions, but it seems that that may have changed. If anyone could let me know, I’d appreciate it.

1 Like

I have no clue what the future of the Biopack is, but there is a Glatorian parts pack available already. A lot of the parts are stylized or a little inaccurate though. There’s also the new parts pack by KingSidorak. It has a few 2008-2009 parts. Not too many though.

3 Likes

Thanks for the tip, I appreciate it.

1 Like

When I downloaded this I went through the automatic installer on the most up to date version of windows 10 and when I finished running it I went through it and every single part included said the specified path could not be found. What could have caused this and is there a way to fix this. I’d be fine doing the manual install but if there’s a larger problem at hand I’d hate to spend the time doing it for the same result. If anyone has had the same experience and been able to resolve, please let me know how or what caused this. Thanks.

oh no, i thought the duplicates were bad before, but now I somehow have 4 different staffs of shattering to add to the doubled incomplete set of rakshi weapons, one of them is even supposed to have a glowing effect, there are probably dozens more duplicates but I can’t sus 'em out because I have a terrible memory and the files are just a list of sequential numbers unrelated to bricklink codes, some of them in ‘parts’ have p or c followed by a number, these are in clusters which suggests duplicates but i don’t know how to go about getting rid of them without ruining something
aside from some minor confusion where I initially extracted the folder into google drive instead of downloading it I thought i had it installed correctly, i used the automatic installer for windows and that should have taken care of everything but none of the old copies got overwritten as far as i can tell

if there was a pack to update studios controls or settings i would download it in a heartbeat, having better hinge controls, i.e. more than 2 functional nodes per part so ccbs is useable, or even just being able to adjust the scroll speed would be amazing, i use a trackpad and its still unmanageable

also upset that there’s still no av-matoran type 2 torso

I’ve dealt with this before. There’s a way to identify which randomly-named files belong to which parts, but it’s tedious.

If you open PartDesigner and go to the menu for importing an existing part, the file name will appear when you hover over the part:

Then from there, you can write down the name and track it down in the CustomParts folder.

This isn’t just a CCBS problem; all parts are limited to two points of rotation, except for Part 30033, apparently:

image

It sucks, but there is also a simple fix for it. I’ll use my Chiara MOC as an example:

image

I want to rotate the model about the ankle, but stud.io picks up the pin as a point of rotation. The simple solution is to just turn the entire shin into a submodel:

image

Now the shin is treated as a single rigid body, and the preferred joints are prioritized.

Alternatively, if you want to avoid submodels for ease of editing, or perhaps to keep other joints free, you can just hold CTRL to select multiple parts, and joints between the selected parts will not be detected:

image

Of course, you have to be careful to select all parts that could be detected as a joint with the selected parts, or else you may have the same problem just in a different place. For example, in the image below, I failed to select one of the pins in the front of the shin (highlighted in pink), and stud.io prioritized its rotation over that of the ankle:

image

I’ve been trying to install the biopack but the manual install isn’t working. how to fix it?

I’ve found a glitch where the elliptical Inika foot piece (part 53549) doesn’t connect with the CCBS hand piece (part 93571) once you slide it into the axle the way you would for the normal hand piece, is there any chance you can fix this?

I just installed the Biopack using the manual install method, creating a Custom Parts folder for everything to go into. However, when I opened up the program, only a handful of pieces were available.

Does anyone have an idea of what I may have done wrong?

EDIT: Nevermind, I fixed the problem; realized I had printed pieces hidden, and for some reason that led to the bulk of the pack getting hidden, printed or not.

2 Likes